New VersaTool Beta (0.1.3)

New Apps, versions, features, etc

New VersaTool Beta (0.1.3)

New postby marwatk on Thu Feb 04, 2010 8:57 pm

Hi all,

Well today was interesting. I think the bug hunting thing is going well. I got a bit overwhelmed for a while so my tracking may have gotten screwed up. If you think I missed your bug let me know (though check out the list first to make sure you reported it first, I got a *lot* of duplicate reports). Eventually I'll move on to features, there are a lot of new applets I want to write, but for now I'm trying to make it solid.

Keep the bugs coming...


I got most of the reported issues fixed there are still a few left outstanding. These I think I fixed or I couldn't reproduce:
  • Also, the text entry interface while putting the URL in was funky...keyboard kept coming up over the entry field. And I could only see one character of what I typed. (roybaum) 2/4@15:33
  • if you're editing a response email, but you go in to insert a canned response, but don't, your message no longer feels that it's 'edited' and lets you back out without saving it (ofutur) 2/4@6:46 (I can't duplicate this one)
  • I got a popup "uncaught exception: task already scheduled or cancelled". This was when i hung up from a phone call (cgiforever) 2/4@13:24
  • Just take a picture can sometimes block media player actions (marwatk)
  • The "run on schedule app" will not run two apps placed on the same time such as the BB alarm and BB browser. (only two apps i have tested so far) And short timing with two apps , I tested about a 1 min gap will cause only the 1st one open as well. (PhamO) 2/4@10:53
  • BB Tour with 4.7 I cannot get the left or right convenience key shortcuts (double-tap and hold) to work. (innov8) 2/4@8:49
  • Sometimes really convenient keys don't work until after a reboot

These ones I definitely fixed (I think), and are fair game for re-reporting:

Fixed in 0.1.3:
  • Error taking picture: format not supported. (jlawler4) 2/4@6:33
  • When I google search from the shortcut, no matter what I type in, it just searches for the word "search" (jlawler4) 2/4@6:35
  • Font issues with day selection makes it impossible to see days selected with certain fonts (Toneberry24) 2/4@6:36
  • When saving a new location, the message "Updating weather" stays at the bottom of the page, even though the stats seem to change. (ofutur) 2/4@6:37
  • "Just take the picture" has trouble running from a home screen icon (Toneberry24) 2/4@6:36
  • Bold 9700 running OS I am having the following problems with it. The try it feature or the alarm itself will not play any tone, whether it is the included, wma, or mp3 files (jline4) 2/4@8:22
  • Editing the title of a homescreen bookmark reports that it already exists (in the case of the weather app) (KRH20) 2/4@8:17
  • "Uncaught exception: object already exists" when pressing on the weather icon on the homescreen (ofutur) 2/4@8:05
  • I set Take a Picture as a bookmark. When I click on the icon, it shows an error "Uncaught exception: object already exists." (dx169) 2/4@8:04
  • UI engine accessed without holding the event lock in weather (arkolbus) 2/4@6:46
  • in the "weather for.." part when i first loaded it this am it would display the the highs and lows for the day right on the stopped doing that. not sure why or if i might have accidentally changed a recently just came back... (jonhedge1) 2/4@12:49
  • I went back in to the "Home Screen Bookmarks" section of the app to delete my duplicate shortcut. It just sits at "Loading" with an empty list now. I can still load the menu, but the options don't do anything at this point. (talon8) 2/4@11:22
  • the font color is also white when you creating folders in the Canned Responses area as well. (c0rinne) 2/4@11:00
  • Popup menus should detect that there's one already open and not open a second
  • Popup menu should default to double press 'End' not press
  • I went to the "Add a Homescreen" app and tried to add a "Take a picture". When I press "back" it asks me if I want to save and I say yes, but it doesn't leave the page. If I press "discard" nothing gets created. (ofutur) 2/4@6:46
  • From searching from Wikipedia is fine but once you hit the end-key it brings you back to the homepage with three options menu open and the keyboard open and will not go away.(a battery pull got it to leave) (PhamO) 2/4@10:02
  • Editing Convenience Keys Creates a copy (talon8) 2/4@9:10
  • Editing a existing bookmark seems to create a copy (like editing convenience keys). In this case, I had it set to launch a URL. I modified the actual URL. (talon8) 2/4@11:22
  • On my Bold 9000 running OS 5.0, when typing the criteria for the Auto Reply, what you are typing does not appear in the box until you are done typing and return to the Edit Auto reply page. (Rumur) 2/4@9:37
  • I set it to "Compose" instead. When I tried to run it I got "Error running action for shortcut key! net.rim.device.api.system.ApplicationManagerException: Error starting null: null" (talon8) 2/4@9:58
  • When I add the BB "Compose" to the pop up menu and tried to run it i got this "Error running menu item! net.rim.decive.api.system.ApplicationMangerException: Error starting null: null" This Error also shows when "altMusic, altPictures, altVideos", "Files" "Music" "net_rim_bb_clock" "Pictures" "SavedMessages" "Videos" (PhamO) 2/4@11:46
  • Home screen shortcuts for weather and tip calculator are displaying on the home screen with the title versatoollauncherx (the_rick311) 2/4@16:10
  • Popup menus don't work as home screen icons (marwatk)
  • Permissions dialog can hang the UI process (Macapple) 2/4@17:42
  • 9700/ : trackpad response is extremely slow and jumpy. Small movement on the pad may cause the icon to jump across entire screen. (maddmaxx308) 2/4@11:55
  • Launchers are titled LauncherX on Pearl 8120 @ (jsolts) 2/4@16:43
Versatile Monkey
For more/quicker help make sure to check out the user manuals
Lead (and only) Monkey
Posts: 2596
Joined: Sun Nov 02, 2008 9:20 pm

Return to Announcements

Who is online

Users browsing this forum: No registered users and 2 guests